Issues with Thoughtly-managed Twilio accounts

Incident Report for Thoughtly

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 11:46 EDT

Identified

There is currently an ongoing issue with inbound & outbound calls made using Thoughtly-managed Twilio accounts. To continue making calls in the meantime, you can connect your own Twilio or Telnyx account using BYOC. If you are an Enterprise or Flex customer, you can request to be switched to Telnyx in the meantime.

https://docs.thoughtly.com/platform/settings/settings#bring-your-own-carrier-byoc
Posted Jul 29, 2025 - 10:02 EDT
This incident affected: Voice Infrastructure (Carrier Gateway).