Investigation: Elevated Queue Time for Automations Launch

Incident Report for Thoughtly

Resolved

Investigation: Elevated Queue Time for Automations Launch
Posted Mar 26, 2025 - 14:25 EDT

Investigating

We are currently investigating an issue where automation runs are experiencing an elevated queue time between launching and starting the first step. Our team is looking into the root cause and will provide updates as soon as possible.
Posted Mar 26, 2025 - 14:20 EDT