Resolved: Elevated CPU Utilization on Database

Incident Report for Thoughtly

Resolved

The CPU utilization on the database in the US East region has returned to normal levels.
Posted Mar 25, 2025 - 13:23 EDT